FANDOM


  • Voilà, j'ai un petit probleme sur le code d'un modèle: j'ai réussi à creer un menu qui permet d'afficher/masquer son contenu, mais bizzarement, ce modèle étant censé s'utiliser en mettant un certains nombres d'arguments (ou pas), quand le menu ne contient pas tout les arguments possibles, il affiche quand meme l'espace normalement occupé par les puces choisis. Voici un exemple simplifié du modèle:

    Menu




      Chargement de l’éditeur...
    • Bonjour.

      Peux tu nous donner le lien du modèle en question ?

      En principe, celà devrait pouvoir se faire avec la ParserFonction if, mais ce serait plus simple de comprendre ce qui ne fonctionne pas avec le modèle lui même.

        Chargement de l’éditeur...
    • voilà le lien (wiki Monster Hunter) à partir de la ligne 82; Merci d'avance !

        Chargement de l’éditeur...
    • J'ai pas le temps de regarder en profondeur, mais vu que les if ne prennent pas les balises ul et li, avoir un espace qui s'affiche ne me semble pas illogique. Je prends le temps de tester ce soir.

        Chargement de l’éditeur...
    • Merci de prendre de ton temps !

        Chargement de l’éditeur...
    • Bonsoir.

      Finalement, le problème n'était pas en lien avec ce que je pensais, c'était simplement la manière dont le code était mis en forme (des retours à la ligne après chaque champ à remplir) qui posait le soucis.

      Je t'ai mis ici deux versions du modèle, rempli et non rempli, pour que tu puisse voir.

        Chargement de l’éditeur...
    • Eh bé, c'était tout bete en fait.... Merci beaucoup en tout cas !

        Chargement de l’éditeur...
    • Un utilisateur de FANDOM
        Chargement de l’éditeur...
Sélectionner ce message
Vous avez sélectionné ce message !
Voir qui a sélectionné ce message
Sauf mention contraire, le contenu de la communauté est disponible sous licence CC-BY-SA .